ML Insight for Consumer/Opening - Dashboards Unable to Load

Incident Report for MeridianLink Statuspage

Resolved

The issue affecting the Dashboards has been resolved, and all services are operating normally.

Thank you for your patience while our teams worked to address this issue. If you continue to experience any problems, please contact Support.
Posted Apr 01, 2026 - 13:04 PDT

Investigating

We are currently investigating reports of errors when trying to load Dashboards affecting ML Consumer/Opening.

Our teams are actively reviewing the situation and working to better understand the scope. We will provide updates as additional information becomes available.

Next update: As soon as we have more details.
Posted Apr 01, 2026 - 12:42 PDT
This incident affected: MeridianLink Insight (Insight Operational Status).