ML Insight - Data Refresh Delay

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Nov 13, 2025 - 11:12 PST

Identified

We’ve identified the cause of the data refresh delay and our team has implemented a fix. Data is currently reprocessing, and we expect the refresh to complete within approximately 2 hours. We’ll provide an update once the refresh is fully completed.

Thank you for your patience and understanding.
Posted Nov 13, 2025 - 08:43 PST
This incident affected: MeridianLink Insight (Data Refresh).