This incident has been resolved. The Treasury Yield Downloader service was re-run across all shared production environments. When the service initially ran, the treasury yield values for the week of 7/7 were not yet available. The Fed published the data later in the morning, and re-running the service successfully retrieved the updated values.
Posted Jul 07, 2025 - 13:32 PDT
Monitoring
All shared environments should now be fixed. For onsite dedicated clients, please submit a support case if you'd like us to apply the update manually; otherwise, it will be deployed automatically on Tuesday, July 8, 2025, at 2:00 AM PT.
Posted Jul 07, 2025 - 12:49 PDT
Identified
Our development team has identified the issue and is currently updating the production servers. The update will be completed shortly.
Posted Jul 07, 2025 - 12:16 PDT
Investigating
We are currently investigating reports that the APOR is not updating in Home Equity applications, causing invalid HPML warnings. We will provide updates as we learn more and work toward a resolution.