ML Consumer/Opening - SECURE Server: Latency issue

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted 26 days ago. Mar 10, 2025 - 12:32 PDT

Monitoring

Development did a IIS recycle to resolve the issue. If you have opened a case, please update the case and confirm that the issue is resolved.
Posted 26 days ago. Mar 10, 2025 - 11:55 PDT

Investigating

Users are reporting slowness on the SECURE server.
Our technical team is investigating the issue.
Posted 26 days ago. Mar 10, 2025 - 11:16 PDT
This incident affected: MeridianLink Consumer / MeridianLink Opening (Consumer App Operational Status).