TazWorks - Digital Delve Outage that impacts multiple vendors

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Jun 05, 2025 - 08:56 PDT

Monitoring

Digital Delve has addressed the issue. Searches are now going through properly to vendors on the Digital Delve platform.
Posted Jun 05, 2025 - 08:34 PDT

Identified

Digital Delve has identified the issue and is working on resolving the issue.
Posted Jun 05, 2025 - 08:09 PDT
This incident affected: TazWorks (InstaScreen Partner Integrations).