TazWorks - Trade House Data Searches Slow To Process

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Jun 04, 2025 - 10:16 PDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 04, 2025 - 09:39 PDT

Identified

TazWorks and Trade House Data is having a technical issue that is causing all searches to take longer than normal to process. We have identified the issue and are working on resolution now. We do not have an ETA on when searches will be processing normally yet.
Posted Jun 04, 2025 - 08:09 PDT
This incident affected: TazWorks (InstaScreen Operational Status, Trade House Data Searches).