Meridianlink Consumer - Error on locked applications

Incident Report for MeridianLink Statuspage

Update

Our developers have identified the issue and are working on a fix, which we expect to deploy tonight. In the meantime, please continue using the workaround provided.
Posted Sep 17, 2026 - 08:32 PDT

Update

We have identified the cause of the issue impacting Meridianlink Consumer: locked applications.

Our teams are working on a resolution and taking steps to restore normal operation.

We will continue to share updates as progress.
Posted Sep 17, 2026 - 08:06 PDT

Identified

We have identified the cause of the issue impacting Meridianlink Consumer: locked applications.

Our teams are working on a resolution and taking steps to restore normal operation. The current workaround If you hit the funding page, you'll need to exit the application. From there, select "Recent" — it will bring you back to the same application, allowing you to get around the issue.

We will continue to share updates as progress.
Posted Sep 17, 2026 - 07:03 PDT
This incident affects: MeridianLink Consumer / MeridianLink Opening (Consumer App Operational Status).