Data Connect - Data Refresh Delay

Incident Report for MeridianLink Statuspage

Update

Current Situation:
We've identified the root cause of the Data Connect service issue.

What's Affected:
Delta Share access to the following tables:
da_derogatory_summary
da_company_info
da_trade_summary
da_credit_report
da_public_record
da_cc_specific_loan_info
da_spouse
da_applicants_address_ssn
da_consumer_vehicle_processings

Data Refresh Status:
All data has been fully refreshed and is current.

Workaround:
While we work to resolve the underlying storage account issue, you can continue your data refresh process by modifying your scripts to exclude the tables listed above. Your pipeline should complete successfully once these tables are removed from your pull requests.

Resolution:
Our engineering team is actively coordinating with our internal infrastructure teams to resolve the storage account configuration issue. We will provide updates as progress is made and will notify you immediately once full access is restored.

We apologize for this disruption and appreciate your patience and flexibility.
Posted Sep 09, 2026 - 13:19 PDT

Update

We have now also identified an issue where the materialized views for certain tables are causing the pipeline to fail for all clients. We are investigating the cause of this issue and will follow up once we have more information.
Posted Sep 09, 2026 - 08:48 PDT

Identified

We experienced a delay in today's Data Connect refresh. Affected pipelines are rerunning and should complete within approximately 3 hours.

Clients on our earlier run times can rerun their pipelines now for data.

We will provide an update as soon as possible. We sincerely apologize for the inconvenience this may cause.
Posted Sep 09, 2026 - 06:35 PDT
This incident affects: Data and Partner Connect (Data Connect Refresh Status).