Mortgage Access impacted by AWS partial global outage

Incident Report for MeridianLink Statuspage

Resolved

Based on the AWS status here https://health.aws.amazon.com/health/status we are marking this incident as Resolved.
Posted Oct 20, 2025 - 14:39 PDT

Identified

AWS is still reporting service issues causing degraded performance. To check on AWS status visit https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 11:55 PDT

Investigating

Mortgage Access POS uses AWS (Amazon Web Services). AWS reported a partial global outage this morning. As a result, Mortgage Access users may experience degraded performance depending on their geographical location. Users can confirm this via a site such as https://downdetector.com/status/aws-amazon-web-services/
Posted Oct 20, 2025 - 10:24 PDT
This incident affected: MeridianLink Mortgage Access (Mortgage Access).