ML Consumer/Opening - Application Latency

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Sep 12, 2025 - 15:09 PDT

Update

After implementing a solution we are continuing to monitor performance.
Posted Sep 12, 2025 - 12:18 PDT

Monitoring

We’ve identified the issue and are actively monitoring. Updates will be shared as they become available.
Posted Sep 12, 2025 - 11:58 PDT

Investigating

We are currently investigating this issue.
Posted Sep 12, 2025 - 07:57 PDT
This incident affected: MeridianLink Consumer / MeridianLink Opening (Consumer App Operational Status).