TazWorks - Trade House Data National Criminal Database Searches Down

Incident Report for MeridianLink Statuspage

Resolved

TazWorks and Trade House Data are back up and running. Searches will go through with a re-dispatch. Please reach out to Support if you need any assistance or have any questions.
Posted Mar 06, 2025 - 11:14 PST

Update

Trade House Data National Criminal Database Searches Down. We believe this is affecting searches that are going direct as well. We are working on identifying the problem and will notify the Status Page once we have more information.
Posted Mar 06, 2025 - 10:52 PST

Investigating

We are currently investigating this issue.
Posted Mar 06, 2025 - 10:44 PST
This incident affected: TazWorks (Trade House Data Searches).