ML DecisionLender 4 Clients Experiencing Latency with Reports

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 12:54 PST

Update

The issue with Decisionlender 4 Reporting latency has been resolved. Please reach out to Support you have any subsequent issues. Thanks,
Posted Nov 24, 2025 - 11:06 PST

Investigating

We’re aware of latency issues affecting Reports in DecisionLender 4. Our team is actively investigating and working to resolve this as quickly as possible. We’ll share additional updates as soon as they’re available.
Posted Nov 24, 2025 - 08:30 PST
This incident affected: MeridianLink DecisionLender (DecisionLender4 Reporting DBS).