ML Consumer/Opening - Live Server Latency Reports

Incident Report for MeridianLink Statuspage

Resolved

No further reports received from users. Users have confirmed that performance is back to normal performance on the Live server.
Posted Jul 28, 2025 - 13:03 PDT

Monitoring

We've recycled our servers and system performance appears to be back to normal levels. We will continue monitoring this.
Posted Jul 28, 2025 - 10:44 PDT

Investigating

Users are reporting extreme latency on the Live server when navigating the system. Our development teams are looking into this.
Posted Jul 28, 2025 - 09:42 PDT
This incident affected: MeridianLink Consumer / MeridianLink Opening (Consumer App Operational Status).