MeridianLink Mortgage and OpenClose Support Phone System Issues

Incident Report for MeridianLink Statuspage

Resolved

The issue has been resolved, and all services are operating normally.

Thank you for your patience while our teams worked to address this issue. If you continue to experience any problems, please contact Support.
Posted Jun 11, 2026 - 11:39 PDT

Update

MeridianLink IT is working with our support phone system provider on this issue. We hope to have a resolution soon.
Posted Jun 11, 2026 - 09:32 PDT

Identified

The Support teams for MeridianLink Mortgage and OpenClose are experiencing phone system issues today. For assistance on Mortgage LOS and related products, please initiate a Chat or Support Case in the Resource Center. For OpenClose LOS and related products, please initiate a Support Case in the Resource Center.
Posted Jun 11, 2026 - 07:50 PDT
This incident affected: MeridianLink Mortgage OpenClose/Optics/CAW (OpenClose) and MeridianLink Mortgage (Mortgage App LOS).