The issue has been resolved, and all services are operating normally.
Thank you for your patience while our teams worked to address this issue. If you continue to experience any problems, please contact Support.
Posted Jul 02, 2026 - 10:58 PDT
Monitoring
A fix has been implemented for the issue affecting PriceMyLoan and we are actively monitoring the environment to ensure stability.
At this time, services are operating normally. We will continue monitoring and provide confirmation once the incident is fully resolved.
Posted Jul 02, 2026 - 09:26 PDT
Update
There is no change to report at this time regarding the issue affecting PriceMyLoan.
Investigation efforts remain ongoing, and our teams continue to actively work toward identifying the cause. We will continue to share updates on a regular cadence, even if no additional information is available.
We understand the impact this may have and appreciate your continued patience as we work toward resolution.
Posted Jul 02, 2026 - 09:17 PDT
Investigating
PriceMyLoan is experiencing issues this morning loading today's rates. Development is working on identifying and resolving this issue. We will post updates as they become available.