ML Consumer/Opening - Credit Pull Issues

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Aug 05, 2025 - 10:59 PDT

Monitoring

Issues reported appear to have resolved themselves. No new reports have been received. We will continue to monitor this on our end.
Posted Aug 05, 2025 - 08:54 PDT

Investigating

Users are running into an issue when pulling credit reports. Users are reporting that the issue is sporadic and that they'll receive a message "The credit report could not be pulled because the credit pull service was unresponsive. Reorder a credit report to continue processing the app."

We are investigating this on our end.
Posted Aug 05, 2025 - 07:28 PDT
This incident affected: MeridianLink Portal (Portal App Credit Reports) and MeridianLink Consumer / MeridianLink Opening (Consumer App Credit Reports).