DecisionLender 4 Experiencing Latency and Processing issues

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved. Your DL 4 system performance should have returned to normal.
Posted Apr 12, 2025 - 12:17 PDT

Identified

We are aware of an issue with the DecisionLender4 environment. We have identified the issue and are actively working on a resolution.
Posted Apr 12, 2025 - 12:08 PDT
This incident affected: MeridianLink DecisionLender (DecisionLender4 App Operational Status).