MLM, MA and OC - Rate Sheets are not getting updated

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 11:26 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 21, 2025 - 10:39 PDT

Identified

The issue has been identified and rate sheets are getting processed.
Posted Oct 21, 2025 - 10:19 PDT

Update

We are continuing to investigate this issue.
Posted Oct 21, 2025 - 10:12 PDT

Investigating

Clients may be experiencing delays in rate sheet updates. We are aware of this issue and are actively investigating. This situation is being closely monitored and we will provide updates within the next 60 min or as the situation warrants.
Posted Oct 21, 2025 - 09:59 PDT
This incident affected: MeridianLink Mortgage OpenClose/Optics/CAW (OpenClose), MeridianLink Mortgage Access (Mortgage Access), and MeridianLink Mortgage (Mortgage App Pricing Engine (PML)).