ML Consumer/Opening Insight - Data Refresh Delay

Incident Report for MeridianLink Statuspage

Resolved

The issue affecting Insight data refresh has been resolved, and all services are operating normally.

Thank you for your patience while our teams worked to address this issue. If you continue to experience any problems, please contact Support.
Posted Jun 18, 2026 - 08:42 PDT

Investigating

We are experiencing a temporary data refresh delay. The technical team is actively working on the issue and we will share an update as soon as it’s resolved.

Affected Data Source: Insight Consumer and Opening
Posted Jun 18, 2026 - 05:43 PDT
This incident affected: MeridianLink Insight (Data Refresh, Insight for Consumer and Opening).