MeridianLink Insight for Mortgage Data Refresh Delay

Incident Report for MeridianLink Statuspage

Resolved

Insight Mortgage data source data is now refreshed, please reach out if there are any issues!
Posted Sep 17, 2026 - 13:08 PDT

Identified

Our team is actively investigating the cause of a data refresh delay affecting the Insight Mortgage data source. They have estimated that this will be resolved in approximately 2 hours and 30 minutes.

We sincerely apologize for the inconvenience this may cause and appreciate your patience as we work to restore normal processing.
Posted Sep 17, 2026 - 09:48 PDT
This incident affected: MeridianLink Insight (Data Refresh, Insight for Mortgage).