ML Consumer/Opening - Slowness on Secure Production

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Feb 17, 2026 - 10:20 PST

Investigating

We received alerts of slowness on the Secure production environment. Autoscaling was activated and performance has improved. We are continuing to monitor response times.
Posted Feb 17, 2026 - 09:11 PST
This incident affected: MeridianLink Consumer / MeridianLink Opening (Consumer App Operational Status).