ML Consumer/Opening - Production Servers latencies

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Feb 28, 2025 - 17:25 PST

Monitoring

We are pleased to report that the server is now stable, and clients have confirmed that it is running as expected. If you are no longer experiencing system slowness or latency, please let us know via your support ticket.

Our development team will continue to monitor the situation closely.
Posted Feb 28, 2025 - 14:03 PST

Investigating

Users are reporting slowness on Production servers. We are currently investigating this.
Posted Feb 28, 2025 - 12:38 PST
This incident affected: MeridianLink Consumer / MeridianLink Opening (Consumer App Operational Status).