Meridianlink Insight Consumer and Opening- Data Refresh Delay

Incident Report for MeridianLink Statuspage

Resolved

Insight Consumer and Opening data source data is now refreshed, please reach out if there are any issues!
Posted Sep 04, 2026 - 17:06 PDT

Investigating

Our team is actively investigating the cause of a data refresh delay affecting the Insight Consumer and Opening data source.

We sincerely apologize for the inconvenience this may cause and appreciate your patience as we work to restore normal processing.
Posted Sep 04, 2026 - 10:49 PDT
This incident affected: MeridianLink Insight (Data Refresh, Insight for Consumer and Opening).