This issue was resolved with a hot fix the night of 5/20/26.
Posted May 21, 2026 - 09:43 PDT
Update
Development is working on a fix for this issue. As soon as we have more information, we will update you here.
Posted May 21, 2026 - 03:08 PDT
Identified
Following a system update released on May 19, users are encountering errors when attempting to create or save drafts in the Workflow Configuration tool. The error references HMDA-related data fields (e.g., sHmdaIncome) and prevents workflow changes from being saved.
Our engineering team is actively working on a targeted data correction that will update the affected workflow records to align with the new field types. This fix does not require a full software release and can be applied directly. No previously saved loan data is affected — this is limited to the workflow configuration tool.
As soon as we have more information, we will update you here.
Posted May 20, 2026 - 11:09 PDT
This incident affected: MeridianLink Mortgage (Mortgage App LOS).