ML Consumer/Opening - Errors when sending documents via IMM

Incident Report for MeridianLink Statuspage

Resolved

This issue has been resolved, and all services are operating normally.

Thank you for your patience while our teams worked to address this issue. If you continue to experience any problems, please contact Support.
Posted May 01, 2026 - 10:27 PDT

Identified

We have identified the cause of the issue impacting the IMM RTS eSignature integration.

A fix for this issue will be deployed to all shared Production environments after business hours today.

We will continue to share updates as progress.
Posted Apr 30, 2026 - 10:39 PDT

Investigating

We are currently investigating reports of errors when sending documents via IMM.
We will provide updates as additional information becomes available.
Posted Apr 30, 2026 - 10:23 PDT
This incident affected: MeridianLink Consumer / MeridianLink Opening (Consumer App - Other Partner Integrations).