Partner Connect Data Refresh Delay

Incident Report for MeridianLink Statuspage

Resolved

Partner Connect data is now refreshed, please reach out if there are any issues!

Root Cause Assessment: The upstream ingestion process exceeded its typical processing window due to increased data volume from a recent onboarding, we are working with internal teams to ensure this does not occur in the future.
Posted Sep 01, 2026 - 09:50 PDT

Investigating

A data refresh delay affecting Partner Connect vendors has been identified. Our team is currently reviewing the cause of the delay. This mornings pipeline is now running and is expected to be completed in the next 30-45 minutes.

We apologize for any inconvenience this may have caused.
Posted Sep 01, 2026 - 09:16 PDT
This incident affected: Data and Partner Connect (Partner Connect Data Refresh).