TazWorks - Vendor Issue with County, State, and Federal Criminal Searches

Incident Report for MeridianLink Statuspage

Resolved

Search can now be re-dispatched to vendors that were previously reporting an error regarding years and jurisdiction groups
Posted Feb 24, 2025 - 11:12 PST

Identified

Vendors using the Digital Delve platform are experiencing errors. Digital Delve is aware of the issue and are working on it.
Posted Feb 24, 2025 - 06:57 PST

Investigating

We are currently investigating the issue
Posted Feb 24, 2025 - 06:46 PST
This incident affected: TazWorks (InstaScreen Operational Status, InstaScreen Partner Integrations).