PriceMyLoan - Expired Rates

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Jan 20, 2026 - 09:58 PST

Update

We are continuing to monitor for any further issues.
Posted Jan 20, 2026 - 09:58 PST

Monitoring

We see that the Rate sheets are processed now
Posted Jan 20, 2026 - 09:58 PST

Update

We are currently investigating the cause and processing rates as they come.
Posted Jan 20, 2026 - 09:45 PST

Update

We are continuing to investigate this issue.
Posted Jan 20, 2026 - 09:31 PST

Investigating

We are currently investigating this issue.
Posted Jan 20, 2026 - 09:29 PST
This incident affected: MeridianLink Mortgage (Mortgage App Pricing Engine (PML)).