TazWorks: Labcorp is experiencing connectivity issues resulting in delays and errors

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Apr 03, 2025 - 07:15 PDT

Identified

Labcorp is aware of the issues and working to resolve the problems.
Posted Mar 31, 2025 - 14:11 PDT
This incident affected: TazWorks (InstaScreen Partner Integrations).