Data Connect Service Outage

Incident Report for MeridianLink Statuspage

Resolved

Data Connect is now operational.

We apologize for the inconvenience this caused to your daily processes today.

Please reach out via support if you run into any issues.
Posted Jul 23, 2026 - 12:24 PDT

Update

We're currently experiencing a service disruption caused by an issue with Microsoft's infrastructure. Microsoft has identified the potential source of the problem and is actively working to resolve it by rerouting traffic to healthy systems and monitoring recovery in real time. They will continue to evaluate the effectiveness of mitigation, assess customer impact, and investigate contributing factors, and will provide additional information as soon as it becomes available.

We're staying close to Microsoft's response to bring services back to full availability as quickly as possible. We'll share updates here as new information becomes available.
Posted Jul 23, 2026 - 11:07 PDT

Investigating

We are currently experiencing an outage with our Data Connect service due to an issue affecting our source infrastructure. Our engineering team is actively working to resolve this issue.

What's happening:

- Data Connect is temporarily unavailable
- Data pipeline operations are impacted
- We are investigating and working toward resolution

What you should do:
We recommend that you do not pull from the pipeline at this time while we work on restoring the service. We will provide updates as we make progress and will notify you immediately once service is restored and it's safe to resume operations.

We apologize for this disruption and appreciate your patience as we work to resolve this as quickly as possible. Please reach out via support if you have any questions or concerns.
Posted Jul 23, 2026 - 08:45 PDT
This incident affected: Data and Partner Connect (Data Connect Operational Status).