MCL (Mortgage Credit Link) issue with credit card payments

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Nov 25, 2025 - 08:42 PST

Monitoring

Development has addressed this issue. We are monitoring the results.
Posted Nov 25, 2025 - 08:22 PST

Investigating

MeridianLink is aware of an MCL issue with credit card payments not processing. This issue began on 11/24/25 around 5:19 PM PST for all vendors. This impacts users IF they order credit reports with the requirement to pay by CCP at the time of order; it will cause orders to fail. Development is aware and is looking into it. We will keep you posted once we have an update.
Posted Nov 25, 2025 - 07:16 PST
This incident affected: MeridianLink Mortgage Credit Link (Mortgage Credit Link App Operational Status, Mortgage Credit Link Credit Integrations), TazWorks (InstaScreen Operational Status, InstaScreen Partner Integrations, QuickApp Pro/QuickLease Pro Operational Status), MeridianLink Consumer / MeridianLink Opening (Consumer App Credit Reports), and MeridianLink Mortgage (Mortgage App LOS, Mortgage App Integrations).