We are continuing to monitor for any further issues.
Posted Apr 22, 2026 - 15:35 PDT
Monitoring
We are no longer observing Experian submission errors. We keep monitoring.
Posted Apr 22, 2026 - 15:31 PDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 22, 2026 - 15:07 PDT
Identified
Experian is currently investigating reports of consumer credit pull failures impacting multiple clients, where requests are returning a TCP SYSTEM UNAVAILABLE error. Their teams are actively reviewing service health and will provide updates on impact and restoration as soon as possible.
We will continue to share updates as we receive additional information.
Posted Apr 22, 2026 - 14:53 PDT
Update
We are getting reports of SYSTEM_UNAVAILABLE errors impacting Experian services. We will continue to share updates as we receive additional information.
Posted Apr 22, 2026 - 14:41 PDT
Investigating
We are getting reports of SYSTEM_UNAVAILABLE errors impacting Experian services. We will continue to share updates as we receive additional information.
Posted Apr 22, 2026 - 14:19 PDT
This incident affected: MeridianLink Mortgage Credit Link (Mortgage Credit Link Credit Integrations), MeridianLink Consumer / MeridianLink Opening (Consumer App Credit Reports), and MeridianLink Mortgage (Mortgage App Integrations).