TazWorks: DataLink/Compass/Transunion MVR Results not Returning

Incident Report for MeridianLink Statuspage

Resolved

We received confirmation from DataLink/Compass/Transunion that the issue has been fixed on their side
Posted Jul 20, 2026 - 13:18 PDT

Monitoring

It appears that MVR results are returning form DataLink/Compass/TransUnion
Posted Jul 20, 2026 - 12:54 PDT

Investigating

We have reached out to DataLink/Compass/Transunion
Posted Jul 20, 2026 - 09:34 PDT
This incident affected: TazWorks (InstaScreen Partner Integrations).