ML Consumer/Opening - CS Server Latency Reports

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Jul 17, 2025 - 12:44 PDT

Monitoring

Development is reporting that the server is back to normal levels. It appears this was a temporary spike that has since resolved itself.
Posted Jul 17, 2025 - 08:10 PDT

Investigating

We are receiving reports that users on CS are experiencing slowness and latency while navigating throughout the system. Our internal teams are investigating this.
Posted Jul 17, 2025 - 07:40 PDT
This incident affected: MeridianLink Consumer / MeridianLink Opening (Consumer App Operational Status).