PriceMyLoan - rates for Paramount Residential Mortgage are delayed

Incident Report for MeridianLink Statuspage

Resolved

The issue has been resolved, and all services are operating normally.

Thank you for your patience while our teams worked to address this issue. If you continue to experience any problems, please contact Support.
Posted Jun 01, 2026 - 10:00 PDT

Investigating

The PriceMyLoan team has advised that the loading of rates for today for Paramount Residential Mortgage has been delayed. As soon as today's rates have been loaded, we will update you here.
Posted Jun 01, 2026 - 08:40 PDT
This incident affected: MeridianLink Mortgage OpenClose/Optics/CAW (OpenClose Pricing Engine (PriceMyLoan)) and MeridianLink Mortgage (Mortgage App Pricing Engine (PML)).