DecisionLender DL 4 Latency Issues

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved. All clients should be experiencing normal system performance now. If you have any residual impacts please reach out to the Support team directly.
Posted Feb 03, 2025 - 13:01 PST

Identified

The issue has been identified and is being corrected. Performance should return to normal shortly. We will have another update soon.
Posted Feb 03, 2025 - 12:16 PST

Investigating

We are currently investigating reports of system latency for the DL 4 systems. We will provide further update soon.
Posted Feb 03, 2025 - 11:48 PST
This incident affected: MeridianLink DecisionLender (DecisionLender4 App Operational Status).