TazWorks - Bluefin and Ezic Payment Gateways are currently down
Incident Report for MeridianLink Statuspage
Resolved
This incident has been resolved.
Posted Mar 22, 2023 - 08:19 PDT
Update
Bluefin and Ezic are continuing to investigate their issue. For the latest status, please check https://status.bluefin.com/
Posted Mar 21, 2023 - 17:07 PDT
Update
Bluefin and Ezic are continuing to investigate their issue.
Posted Mar 21, 2023 - 14:54 PDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 21, 2023 - 12:25 PDT
Identified
Bluefin and Ezic are investigating reports of processing issues at Ezic affecting only a select group of merchants utilizing the Bluefin Gateway. Their team of engineers is working with Ezic to find a solution. They apologize for the inconvenience and they thank you for your patience.

https://status.bluefin.com/
Posted Mar 21, 2023 - 11:17 PDT
This incident affected: TazWorks (InstaScreen Operational Status).