ML Consumer/Opening: Shared Production - Missing Resolve Fraud Option for IVL Apps

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted May 29, 2026 - 08:00 PDT

Update

The fix deployment was completed. We are following up to confirm that the missing Resolve Fraud option is now working as expected.
If you have an open case with Support, please add a comment to confirm the issue has been resolved on your end.
Posted May 29, 2026 - 05:29 PDT

Monitoring

We are deploying a fix tonight across all shared production environments for the Missing Resolve Fraud option in IVL apps.
Maintenance is scheduled to begin at 7 PM PT, with each environment expected to be down for approximately 30–40 minutes.

CS will begin at 8 PM PT. Secure, HS, and WS environments will begin at 9 PM PT.
Posted May 28, 2026 - 13:46 PDT

Update

We have identified the cause of the issue impacting fraud warning resolution and intermittent latency.

Our teams are actively working on a fix and are currently completing the build. Once finalized, we will proceed through testing and then deployment to production.

We will continue to provide updates as progress is made.
Posted May 28, 2026 - 10:32 PDT

Update

Our teams are actively working on a fix. Updated images are currently being built, after which we will deploy to testing and then move to production.

We are targeting approximately 90 minutes for full restoration, barring any unexpected issues.

We will continue to share updates as progress is made.
Posted May 28, 2026 - 09:11 PDT

Update

We have identified the cause of the issue impacting fraud warning resolution.

Our teams are actively working on a fix.

We will continue to share updates as progress is made.
Posted May 28, 2026 - 07:57 PDT

Identified

We have identified the cause of the issue: the inability to resolve fraud warnings.

Our teams are working on a resolution and taking steps to restore normal operation.

We will continue to share updates as progress.
Posted May 28, 2026 - 06:44 PDT

Investigating

We are currently investigating reports of being unable to resolve fraud warnings affecting ML Consumer IVL loans.

Our teams are actively reviewing the situation and working to better understand the scope. We will provide updates as additional information becomes available.

Next update: as soon as we have more details
Posted May 28, 2026 - 05:52 PDT
This incident affected: MeridianLink Consumer / MeridianLink Opening (Consumer App Fraud Prevention Vendors).