Engage Outage

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Dec 17, 2025 - 07:40 PST

Investigating

We are currently experiencing a system outage affecting MeridianLink Engage, including access to the platform.

Current Status:
Our team is actively investigating the issue to identify the cause and restore full functionality as quickly as possible.

Impact:
Users may be unable to log into Engage
Some pages may experience degraded performance or fail to load

Next Update:
We will provide another update as soon as we have additional information.
Thank you for your patience as we work to resolve this issue.
Posted Dec 17, 2025 - 06:56 PST
This incident affected: MeridianLink Engage (Engage App Operational Status).