ML Consumer/Opening - CS Server Latency Reports

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved. We’ve received confirmation that the CS Server has resumed normal performance.
Posted Jan 22, 2026 - 11:45 PST

Investigating

Clients are reporting slowness and latency when navigating on the CS Server. Our technical teams are looking into this.
Posted Jan 22, 2026 - 09:55 PST
This incident affected: MeridianLink Consumer / MeridianLink Opening (Consumer App Operational Status).