MeridianLink OpenClose: DecisionAssist rates for PennyMac - rate update delayed

Incident Report for MeridianLink Statuspage

Resolved

PennyMac has resolved its SFTP issue, we have received their rate sheet, and their rates have been uploaded into DecisionAssist. This issue is resolved.
Posted Aug 22, 2025 - 10:12 PDT

Identified

PennyMac has notified MeridianLink that they have a technical issue on their end. Once they resolve their issue, we will receive their rates for today.
Posted Aug 22, 2025 - 09:34 PDT

Investigating

Due to a technical issue, the uploading of today's rates for PennyMac into the DecisionAssist pricing engine has been delayed. IT is working towards a resolution.

This impacts only lenders who use rates from PennyMac. This impacts OpenClose LOS and Mortgage Access POS for OpenClose clients.
Posted Aug 22, 2025 - 09:01 PDT
This incident affected: MeridianLink Mortgage OpenClose/Optics/CAW (OpenClose, OpenClose Pricing Engine (DecisionAssist)) and MeridianLink Mortgage Access (Mortgage Access).