ES, ST and Live Server Latency

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Nov 17, 2025 - 10:58 PST

Monitoring

Development reports normal response on all servers. If you have an open case related to these servers, please update your case with confirmation.
Posted Nov 17, 2025 - 09:52 PST

Update

Development reports normal response on the Live server. If you have an open case related to these servers, please update your case with confirmation.
Posted Nov 17, 2025 - 09:51 PST

Update

Development reports normal response on the ST server. If you have an open case related to these servers, please update your case with confirmation.
Posted Nov 17, 2025 - 09:01 PST

Investigating

We are currently investigating this issue.
Posted Nov 17, 2025 - 07:57 PST
This incident affected: MeridianLink Consumer / MeridianLink Opening (Consumer App Operational Status).