MCL - Equifax is not available

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 15:07 PDT

Update

Equifax is actively working on this issue and expect to have services fully restored shortly.
Posted Jun 12, 2025 - 13:26 PDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 12, 2025 - 12:38 PDT

Identified

The issue has been identified and it is with the provider (Equifax).
Posted Jun 12, 2025 - 11:56 PDT

Investigating

We are currently investigating this issue.
Posted Jun 12, 2025 - 11:29 PDT
This incident affected: MeridianLink Mortgage Credit Link (Mortgage Credit Link Credit Integrations).