ML Consumer/Opening - Secure Server Latency Reported

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Feb 18, 2025 - 13:54 PST

Monitoring

We have successfully implemented a fix and have received confirmation that performance has returned to normal.
Posted Feb 18, 2025 - 10:07 PST

Investigating

Some clients are reporting slowness on the Secure server. We are currently investigating this.
Posted Feb 18, 2025 - 09:31 PST
This incident affected: MeridianLink Consumer / MeridianLink Opening (Consumer App Operational Status).