Dealertrack has informed us that the issue has been resolved. As of approximately 11:30 AM EST, services should be functioning normally.
Please review and let us know if you continue to experience any issues.
Posted Sep 04, 2026 - 10:19 PDT
Monitoring
We will continue to monitor the situation and provide updates as additional information becomes available.
Posted Sep 04, 2026 - 07:38 PDT
Identified
Our team has investigated the reports and confirmed that Dealertrack has been notified of the issue. We are working with them to determine the root cause and obtain additional information regarding resolution efforts.
Posted Sep 04, 2026 - 07:36 PDT
Investigating
We have received reports that Dealertrack e-Contracting is not functioning properly. In addition, some clients have reported that decisioning updates are not being reflected in Dealertrack as expected.
Posted Sep 04, 2026 - 07:36 PDT
This incident affected: MeridianLink DecisionLender (DecisionLender4 Partner Integrations).