ML Consumer/Opening - CS Server Latency Reports

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Jun 30, 2025 - 14:34 PDT

Monitoring

Our technical team has taken corrective action by flushing the cache and recycling a few virtual machines. System performance has since returned to normal levels.
We’ve also received confirmation from users that latency has noticeably improved.
We will continue to monitor the system closely to ensure stability.
Posted Jun 30, 2025 - 11:02 PDT

Update

Our technical team is actively investigating the root cause and working to resolve this issue as quickly as possible.
We will continue to provide updates as progress is made.
Posted Jun 30, 2025 - 09:44 PDT

Investigating

Clients are reporting that they're experiencing latency on the CS Server when navigating applications in the system.
Posted Jun 30, 2025 - 07:07 PDT
This incident affected: MeridianLink Consumer / MeridianLink Opening (Consumer App Operational Status).