Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 24, 2026 - 19:00 PDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Apr 23, 2026 - 09:56 PDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Apr 23, 2026 - 08:09 PDT
Scheduled
Mortgage Credit Link (MCL) will be undergoing scheduled infrastructure improvements. During this maintenance window, please note the following scope and impact:
--Impact is limited to Credit Reporting Agencies (CRAs) using Mortgage Credit Link (MCL), MeridianLink TazWorks, and MeridianLink CreditAPI only.
--MCL will be fully offline during the maintenance window, and all credit and verification requests will be unavailable until service is restored.
No other MeridianLink products or Consumer-facing applications are affected.
Posted Apr 22, 2026 - 14:28 PDT
This scheduled maintenance affected: MeridianLink Mortgage Credit Link (Mortgage Credit Link App Operational Status, Mortgage Credit Link Credit Integrations, Mortgage Credit Link Additional Product Integrations) and TazWorks (InstaScreen Operational Status, InstaScreen Partner Integrations, QuickApp Pro/QuickLease Pro Operational Status, Trade House Data Searches).