ML Consumer - Connection error occurs with Precise ID

Incident Report for MeridianLink Statuspage

Resolved

Our IT team has implemented additional firewall whitelisting for a new URL provided by Experian, which has resolved the recent connectivity issues.

Action required for offsite clients: Please have your IT team open your firewall to allow communication to/from gateway.experian.com.

If you continue to experience issues after making this change, please reach out to our support team.
Posted Jul 21, 2026 - 12:21 PDT

Update

Experian is still investigating this on their end.
Posted Jul 20, 2026 - 13:22 PDT

Monitoring

We have identified the cause of the issue impacting Experian Precise ID.

Experian is working on a resolution and taking steps to restore normal operation. They identified an IP address and have updated their allow list.
Posted Jul 20, 2026 - 08:40 PDT

Update

We are continuing to investigate reports of errors affecting Precise ID.

Our teams are actively reviewing the situation and working to better understand the scope. We will provide updates as additional information becomes available.
Posted Jul 20, 2026 - 08:00 PDT

Investigating

We are currently investigating reports of errors affecting Precise ID.

Our teams are actively reviewing the situation and working to better understand the scope. We will provide updates as additional information becomes available.
Posted Jul 20, 2026 - 06:55 PDT
This incident affected: MeridianLink Consumer / MeridianLink Opening (Consumer App Fraud Prevention Vendors).