ML Consumer/Opening - JD Power Dropdowns Not Populating Data for Other - Classic Cars

Incident Report for MeridianLink Statuspage

Resolved

This incident is resolved. We collaborated with the vendor to address the issue of blank values returned from their API. After clearing the cached bad results, we recycled the root website application pool on the affected servers. This forced a clean call to JD Power, which returned valid results.
Posted Jul 31, 2025 - 04:33 PDT

Investigating

Users are reporting that in Production the dropdowns for Classic Cars aren't populating data when using the JD Power (fka NADA) tool.
We are looking into this internally as well as reached out to JD Power directly.
Posted Jul 30, 2025 - 10:42 PDT
This incident affected: MeridianLink Consumer / MeridianLink Opening (Consumer App Vehicle Valuation).