DecisionLender 4 - Password Retrieval Issues
Incident Report for MeridianLink Statuspage
Resolved
This issue has now been resolved; users should be able to receive passwords via email in DEMO as expected.
Posted Mar 21, 2023 - 11:49 PDT
Identified
The issue has been identified and will be fixed shortly.
Posted Mar 21, 2023 - 11:00 PDT
Investigating
We are currently investigating issues where users are not receiving new passwords via email in DEMO only.
Posted Mar 21, 2023 - 09:19 PDT
This incident affected: MeridianLink DecisionLender (DecisionLender4 App Operational Status).